Market data feed not available for CELO
Incident Report for Aquanow
Resolved
This incident has been resolved.
Posted Dec 01, 2022 - 21:00 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Dec 01, 2022 - 03:00 UTC
This incident affected: Market Data.